Problems with the bolts that connect the unifoil fuse to the wing

Has anyone encountered problems connecting a unifoil fuse to the front wing? It seems the titanium bolts that connect the fuse to the wing, at least the one in the back, is a tiny bit too long. I just can’t seem to get it tight enough Unless I really hunker down on it to the point I am afraid I’m gonna strip the head of the bolt. If I don’t do that there’s a bit of play between the front wing and the fuse which sucks.
Happens with both progression 140 and progression 170 front wings.
I am travelling with the board on Tuesday and am afraid I am going to strip it while I am away.
Anyone seen this? Thanks in advance for any insights.

If you have some misaligned or poorly aligned holes on your fuse just send pictures to Unifoil’s support and they’ll help you get a new one, have worked with them twice and they resolved the issue happily and easily

1 Like

I had a fuse with fouled threads from the factory. Could be that - and if so, a thread cleaning bolt helped to some degree. Or maybe your bolts are just too long.

1 Like

try the short screws for your tail. Ive seen and experienced this issue a couple times and the solution is the shortest screw for the tail. if you have shims the tail would fit with the larger screw or youll have to get another one.

1 Like

I already tried the shortest of the 4 short bolts (one is slightly shorter than the others it seems …but almost imperceptibly. )

I will make a trip to the local hardware store to see if I can find a thread cleaning bolt. I will also reach out to the folks at unifoil when I get back from the trip.

My Uni kit came with four total of the short bolts, in pairs of two slightly different lengths (maybe 1mm difference? It is noticeable, but easy to miss). The med fuse attaches to the 140 with 1 short and 1 long bolt. It sounds like you are missing the short ones?

I assume you aren’t shimming, but if you have the shim pack there is a zero shim that should work to fill up the space too.

Yup I had the same issue with my Unifoil gear. They seem to be tapped at irregular lengths. I was lucky that I had some shorter bolts lying around so I made it work.